solana_pay 1.0.0 copy "solana_pay: ^1.0.0" to clipboard
solana_pay: ^1.0.0 copied to clipboard

Create transaction and payment requests using Solana Pay

7
likes
140/ 160
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 6 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
solana ^0.25.0 0.25.0 0.30.4
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
bip39 - 1.0.6 1.0.6
borsh_annotation - 0.3.1+5 0.3.1+5
collection - 1.19.0 1.19.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
cryptography - 2.7.0 2.7.0
decimal - 2.3.3 3.0.2
ed25519_hd_key - 2.2.1 2.2.1
ffi - 2.1.2 2.1.2
freezed_annotation - 2.4.1 2.4.1
hex - 0.2.0 0.2.0
http - 0.13.6 1.2.1
http_parser - 4.1.0 4.1.0
js - 0.6.7 0.7.1
json_annotation - 4.9.0 4.9.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
pinenacl - 0.5.1 0.6.0
pointycastle - 3.9.1 3.9.1
rational - 2.2.3 2.2.3
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1
web_socket_channel - 2.4.5 3.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.25.0` on solana does not support the stable version `0.26.0`.

Try running dart pub upgrade --major-versions solana to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

7
likes
140
pub points
0%
popularity

Publisher

verified publisherbxplus.co

Create transaction and payment requests using Solana Pay

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

solana

More

Packages that depend on solana_pay