softcorp_flutter_core 1.0.67
softcorp_flutter_core: ^1.0.67 copied to clipboard

Core Flutter building blocks for Softcorp projects.

0
likes
90/ 130
pub points
52%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/softcorp-io/softcorp_flutter_core was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 210 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

lib/animated_gradient/animated_gradient.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/constants.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^1.0.21.0.41.0.4
flutterflutter0.0.00.0.0
flutter_bloc^7.3.17.3.38.0.0
flutter_gradient_colors^2.1.12.1.12.1.1
flutter_svg^0.23.0+10.23.0+11.0.0
google_nav_bar^5.0.55.0.55.0.5
loading_indicator^3.0.23.0.23.0.2
multi_select_flutter^4.0.04.0.04.0.0
progress_state_button^1.0.31.0.41.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
bloc-7.2.18.0.1
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
nested-1.0.01.0.0
path_drawing-0.5.1+11.0.0
path_parsing-0.2.11.0.0
petitparser-4.4.04.4.0
provider-6.0.16.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^7.3.1` on flutter_bloc does not support the stable version `8.0.0`, that was published 14 days ago.

When flutter_bloc is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_bloc to update the constraint.

The constraint `^0.23.0+1` on flutter_svg does not support the stable version `1.0.0`, that was published 0 days ago.

When flutter_svg is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions flutter_svg to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.