socky_cli 0.1.0+1
socky_cli: ^0.1.0+1 copied to clipboard

A starting point for Dart libraries or applications.

0
likes
55/ 130
pub points
0%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 55 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 71 API elements (22.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:socky_cli/commands/dev.dart that imports:
  • package:socky_cli/commands/pub.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/commands/pub.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/util.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.32.0 <2.0.00.41.12.8.0
args^1.0.01.6.02.3.0
code_builder^3.0.03.7.04.1.0
dart_style^1.0.01.3.122.2.0
glob^1.1.01.2.02.0.2
http^0.12.00.12.20.13.4
inflection2^0.4.20.4.30.4.3
io^0.3.20.3.51.0.3
mustache4dart^3.0.0-dev.1.03.0.0-dev.1.03.0.0-dev.1.0
path^1.0.01.8.01.8.0
prompts^1.0.01.3.12.0.0
pubspec_parse^0.1.20.1.81.1.0
quiver^2.0.02.1.53.0.1+1
recase^2.0.02.0.14.0.0
shutdown^0.4.00.4.30.4.3
watcher^0.9.70.9.7+151.0.1
yaml^2.0.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.031.0.0
async-2.8.22.8.2
build-1.6.22.1.1
build_config-0.4.51.0.0
build_daemon-2.1.103.0.1
build_resolvers-1.5.32.0.5
build_runner-1.11.1+12.1.5
build_runner_core-6.1.77.2.2
built_collection-5.1.15.1.1
built_value-8.1.38.1.3
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
file-5.2.16.1.2
fixnum-1.0.01.0.0
graphs-0.2.02.1.0
http_multi_server-2.2.03.0.1
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
logging-0.11.41.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.11.0.1
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
pedantic-1.11.11.11.1
pool-1.5.01.5.0
pub_semver-1.4.42.1.0
reflectable-2.2.93.0.4
shelf-0.7.91.2.0
shelf_web_socket-0.2.4+11.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
web_socket_channel-1.2.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 13 issues. Showing the first 2:

The constraint `>=0.32.0 <2.0.0` on analyzer does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.0.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.8.1 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.