snapkit 2.0.0 copy "snapkit: ^2.0.0" to clipboard
snapkit: ^2.0.0 copied to clipboard

A Flutter Plugin for integrating with Snapchat's SnapKit on iOS & Android

31
likes
120/ 140
pub points
74%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

41 out of 66 API elements (62.1 %) have documentation comments.

Some symbols that are missing documentation: SnapchatButton, SnapchatButton.SnapchatButton, SnapchatButton.SnapchatButtonColors, SnapchatButton.SnapchatButtonColors.SnapchatButtonColors, SnapchatButton.SnapchatButtonExtension.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:snapkit/snapkit.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:snapkit/snapkit.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:snapkit/snapkit.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:snapkit/snapkit.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The file name 'SnapchatButton.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/SnapchatButton.dart

INFO: The import of 'dart:ui' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/material.dart'.

lib/SnapchatButton.dart:1:8

  ╷
1 │ import 'dart:ui';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/SnapchatButton.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.1
path_provider ^2.0.2 2.1.2 2.1.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
ffi - 2.1.2 2.1.2
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
path_provider_android - 2.2.2 2.2.2
path_provider_foundation - 2.3.2 2.3.2
path_provider_linux - 2.2.1 2.2.1
path_provider_platform_interface - 2.1.2 2.1.2
path_provider_windows - 2.2.1 2.2.1
platform - 3.1.4 3.1.4
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
win32 - 5.2.0 5.2.0
xdg_directories - 1.0.4 1.0.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

31
likes
120
pub points
74%
popularity

Publisher

verified publisherjacobbrasil.com

A Flutter Plugin for integrating with Snapchat's SnapKit on iOS & Android

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, http, path_provider

More

Packages that depend on snapkit