smooth_video_progress 0.0.4 copy "smooth_video_progress: ^0.0.4" to clipboard
smooth_video_progress: ^0.0.4 copied to clipboard

An interpolated progress builder for video_player controllers

28
likes
130/ 140
pub points
91%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 7 API elements (85.7 %) have documentation comments.

Some symbols that are missing documentation: smooth_video_progress.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ macOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:smooth_video_progress/smooth_video_progress.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, macOS, Web.
Package does not support platform `Linux`.

Because:

  • package:smooth_video_progress/smooth_video_progress.dart that imports:
  • package:video_player/video_player.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package not compatible with platform Web

Because:

  • package:smooth_video_progress/smooth_video_progress.dart that imports:
  • package:video_player/video_player.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_hooks ^0.18.4 0.18.6 0.20.5
video_player ^2.4.2 2.8.6 2.8.6
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
csslib - 1.0.0 1.0.0
flutter_web_plugins - 0.0.0 0.0.0
html - 0.15.4 0.15.4
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
vector_math - 2.1.4 2.1.4
video_player_android - 2.4.14 2.4.14
video_player_avfoundation - 2.5.7 2.5.7
video_player_platform_interface - 6.2.2 6.2.2
video_player_web - 2.3.0 2.3.0
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.4` on flutter_hooks does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions flutter_hooks to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.