smart_arrays_plot_polyline 2.0.1
smart_arrays_plot_polyline: ^2.0.1

Dart js
Flutter web

Plots small or big 1D arrays in form of polylines in the browser, optionally with axes and legend text. Many configuration options of the view are provided.

1
likes
90 / 110
pub points
67 %
popularity

We analyzed this package on Nov 15, 2020, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 93 out of 299 API elements (31.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:smart_arrays_plot_polyline/smart_arrays_plot_polyline.dart that imports:
  • package:smart_arrays_plot_polyline/src/utils.dart that imports:
  • dart:html
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 51 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/axis.dart:315:19

    ╷
315 │     _attributes = new Map.from(AXIS_DEFAULT_ATTRIBUTES); // init. attributes
    │                   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/axis.dart

INFO: Unnecessary new keyword.

lib/src/axis.dart:461:23

    ╷
461 │     labelsContainer = new SvgSvgElement(); // now position the labels here
    │                       ^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/axis.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
build_runner^1.6.21.10.41.10.4
build_web_compilers^2.1.42.12.22.13.0
pedantic^1.5.01.9.21.9.2
smart_arrays_base^2.0.02.1.02.1.0
smart_arrays_compress^2.0.72.1.02.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.013.0.0
analyzer-0.40.60.41.0
archive-2.0.132.0.13
args-1.6.01.6.0
async-2.4.22.4.2
bazel_worker-0.1.250.1.25
build-1.5.01.5.0
build_config-0.4.20.4.2
build_daemon-2.1.42.1.4
build_modules-3.0.03.0.0
build_resolvers-1.4.31.4.3
build_runner_core-6.0.36.0.3
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
charcode-1.1.31.1.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
code_builder-3.5.03.5.0
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
dart_style-1.3.91.3.9
fixnum-0.10.110.10.11
glob-1.2.01.2.0
graphs-0.2.00.2.0
http_multi_server-2.2.02.2.0
http_parser-3.1.43.1.4
io-0.3.40.3.4
js-0.6.20.6.2
json_annotation-3.1.03.1.0
logging-0.11.40.11.4
matcher-0.12.90.12.9
meta-1.2.31.2.3
mime-0.9.70.9.7
node_interop-1.2.01.2.0
node_io-1.1.11.1.1
package_config-1.9.31.9.3
path-1.7.01.7.0
pool-1.4.01.4.0
protobuf-1.1.01.1.0
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.52.1.5
scratch_space-0.0.4+20.0.4+2
shelf-0.7.90.7.9
shelf_web_socket-0.2.30.2.3
source_maps-0.10.90.10.9
source_span-1.7.01.7.0
stack_trace-1.9.61.9.6
stream_channel-2.0.02.0.0
stream_transform-1.2.01.2.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
timing-0.1.1+20.1.1+2
typed_data-1.2.01.2.0
watcher-0.9.7+150.9.7+15
web_socket_channel-1.1.01.1.0
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
90
pub points
67%
popularity

Plots small or big 1D arrays in form of polylines in the browser, optionally with axes and legend text. Many configuration options of the view are provided.

Homepage

Documentation

API reference

Uploader

specpad@gmail.com

License

BSD (LICENSE)

Dependencies

build_runner, build_web_compilers, pedantic, smart_arrays_base, smart_arrays_compress

More

Packages that depend on smart_arrays_plot_polyline