slate_lms 0.0.7 icon indicating copy to clipboard operation
slate_lms: ^0.0.7 copied to clipboard

⌨️ The API client library for Slate LMS, written in Flutter/Dart.

2
likes
110/ 130
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 110 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/Slate-LMS/flutter-api was unreachable.

Repository URL doesn't exist.

At the time of the analysis https://github.com/Slate-LMS/flutter-api was unreachable.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/Slate-LMS/flutter-api/issues was unreachable.

Documentation URL doesn't exist.

At the time of the analysis https://github.com/Slate-LMS/flutter-api was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 4 API elements (50.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

2
likes
110
pub points
0%
popularity

Publisher

verified publisher iconthinkalex.dev

⌨️ The API client library for Slate LMS, written in Flutter/Dart.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Icon for licenses.GPL-3.0 (LICENSE)

Dependencies

flutter

More

Packages that depend on slate_lms