skeleton_loader 2.0.0+4 copy "skeleton_loader: ^2.0.0+4" to clipboard
skeleton_loader: ^2.0.0+4 copied to clipboard

A Flutter Package which provides a fully customizable loading skeleton for your app,

230
likes
140/ 160
pub points
96%
popularity

We analyzed this package 4 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 27 API elements (70.4 %) have documentation comments.

Some symbols that are missing documentation: skeleton_loader, skeleton_loader.SkeletonDirection, skeleton_loader.SkeletonDirection.SkeletonDirection, skeleton_loader.SkeletonGridLoader, skeleton_loader.SkeletonGridLoader.SkeletonGridLoader.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The part-of directive uses a library name.

lib/src/skeleton_grid.dart:1:1

  ╷
1 │ part of skeleton_loader;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/skeleton_grid.dart

INFO: The part-of directive uses a library name.

lib/src/skeleton_list.dart:1:1

  ╷
1 │ part of skeleton_loader;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/skeleton_list.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
shimmer ^2.0.0 2.0.0 3.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on shimmer does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions shimmer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

230
likes
140
pub points
96%
popularity

Publisher

verified publisherlhamy.codes

A Flutter Package which provides a fully customizable loading skeleton for your app,

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, shimmer

More

Packages that depend on skeleton_loader