skawa_components 1.5.3 icon indicating copy to clipboard operation
skawa_components: ^1.5.3 copied to clipboard

Platformweb

Additional components for AngularDart based on Material Design principles. These reusable components are not part of the official Material Components library.

4
likes
90/ 140
pub points
43%
popularity

We analyzed this package 13 hours ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 63 out of 435 API elements (14.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Web

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:skawa_components/skawa_components.dart that imports:
  • package:skawa_components/infobar/infobar.dart that imports:
  • package:angular_components/material_button/material_button.dart that imports:
  • package:angular_components/material_button/material_button_base.dart that imports:
  • package:angular_components/button_decorator/button_decorator.dart that imports:
  • package:angular_components/utils/browser/events/events.dart that imports:
  • package:angular_components/utils/browser/feature_detector/feature_detector.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform iOS

Because:

  • package:skawa_components/skawa_components.dart that imports:
  • package:skawa_components/infobar/infobar.dart that imports:
  • package:angular_components/material_button/material_button.dart that imports:
  • package:angular_components/material_button/material_button_base.dart that imports:
  • package:angular_components/button_decorator/button_decorator.dart that imports:
  • package:angular_components/utils/browser/events/events.dart that imports:
  • package:angular_components/utils/browser/feature_detector/feature_detector.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform Windows

Because:

  • package:skawa_components/skawa_components.dart that imports:
  • package:skawa_components/infobar/infobar.dart that imports:
  • package:angular_components/material_button/material_button.dart that imports:
  • package:angular_components/material_button/material_button_base.dart that imports:
  • package:angular_components/button_decorator/button_decorator.dart that imports:
  • package:angular_components/utils/browser/events/events.dart that imports:
  • package:angular_components/utils/browser/feature_detector/feature_detector.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform Linux

Because:

  • package:skawa_components/skawa_components.dart that imports:
  • package:skawa_components/infobar/infobar.dart that imports:
  • package:angular_components/material_button/material_button.dart that imports:
  • package:angular_components/material_button/material_button_base.dart that imports:
  • package:angular_components/button_decorator/button_decorator.dart that imports:
  • package:angular_components/utils/browser/events/events.dart that imports:
  • package:angular_components/utils/browser/feature_detector/feature_detector.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
Package not compatible with platform macOS

Because:

  • package:skawa_components/skawa_components.dart that imports:
  • package:skawa_components/infobar/infobar.dart that imports:
  • package:angular_components/material_button/material_button.dart that imports:
  • package:angular_components/material_button/material_button_base.dart that imports:
  • package:angular_components/button_decorator/button_decorator.dart that imports:
  • package:angular_components/utils/browser/events/events.dart that imports:
  • package:angular_components/utils/browser/feature_detector/feature_detector.dart that imports:
  • package:js/js_util.dart that imports:
  • dart:js_util
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

INFO: Using a colon as a separator before a default value is deprecated and will not be supported in language version 3.0 and later.

lib/code_mirror/code_mirror_config.dart:77:22

   ╷
77 │       this.indentUnit: 2,
   │                      ^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/code_mirror/code_mirror_config.dart

INFO: The name Optional is shown, but isn't used.

lib/feature_toggle/feature_toggle.dart:1:93

  ╷
1 │ import 'package:angular/angular.dart' show TemplateRef, ViewContainerRef, Directive, Input, Optional;
  │                                                                                             ^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/feature_toggle/feature_toggle.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angular^6.0.06.0.17.0.2
angular_components^1.0.01.0.31.0.3
diff_match_patch^0.3.00.3.00.4.1
intl^0.16.00.16.10.18.0
js^0.6.1+10.6.70.6.7
markdown^3.0.03.0.06.0.1
meta^1.2.21.9.01.9.0
sass_builder^2.1.22.1.32.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-12.0.052.0.0
analyzer-0.40.75.4.0
angular_ast-1.0.12.0.1
angular_compiler-1.0.12.0.2
angular_forms-3.0.04.0.1
args-1.6.02.3.2
async-2.10.02.10.0
build-1.6.22.3.1
build_config-0.4.71.1.1
built_collection-4.3.25.1.1
built_value-7.1.08.4.3
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.2
cli_repl-0.2.30.2.3
cli_util-0.2.00.3.5
code_builder-3.7.04.4.0
collection-1.17.11.17.1
convert-2.1.13.1.1
crypto-2.1.53.0.2
csslib-0.16.20.17.2
dart_internal-0.2.60.2.6
dart_style-1.3.102.2.4
file-5.2.16.1.4
fixnum-0.10.111.1.0
glob-1.2.12.1.1
http-0.12.20.13.5
http_parser-3.1.44.0.2
json_annotation-4.8.04.8.0
logging-0.11.41.1.1
matcher-0.12.140.12.14
node_interop-1.2.12.1.0
node_io-1.2.02.2.0
observable-0.23.00.24.0
package_config-1.9.32.1.0
package_resolver-1.0.101.0.10
path-1.8.31.8.3
pedantic-1.11.11.11.1
protobuf-1.1.42.1.0
pub_semver-1.4.42.1.3
pubspec_parse-0.1.81.2.1
quiver-2.1.53.2.1
sass-1.32.81.58.0
source_gen-0.9.10+21.2.7
source_maps-0.10.110.10.11
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
stream_transform-2.1.02.1.0
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
tuple-1.0.32.0.1
typed_data-1.3.11.3.1
watcher-0.9.7+151.0.2
yaml-2.2.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^6.0.0` on angular does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions angular to update the constraint.

The constraint `^0.3.0` on diff_match_patch does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions diff_match_patch to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.9.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Dart 2.19.1.

4
likes
90
pub points
43%
popularity

Publisher

unverified uploader

Additional components for AngularDart based on Material Design principles. These reusable components are not part of the official Material Components library.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

angular, angular_components, diff_match_patch, intl, js, markdown, meta, sass_builder

More

Packages that depend on skawa_components