sitegen 2.0.1
sitegen: ^2.0.1 copied to clipboard

Static site generator for Dart, webserver included.

3
likes
40/ 130
pub points
0%
popularity

We analyzed this package 28 hours ago, and awarded it 40 pub points (of a possible 130):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 10 links are insecure.

README.md:24:4

   ╷
24 │ <p><a href="http://technology.customink.com/blog/2014/10/09/understanding-and-using-sass-load-paths/">Understanding and Using Sass Load Paths</a></p>
   │    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

0/5 points: Provide a valid CHANGELOG.md

Links in `CHANGELOG.md` should be secure. 37 links are insecure.

CHANGELOG.md:3:5

  ╷
3 │ <h2><a href="http://github.com/mikemitterer/dart-sitegen/compare/v2.0...HEAD">Unreleased</a></h2>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 84 API elements (17.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:sitegen/sitegen.dart that imports:
  • package:packages/packages.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

bin/sitegen.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/sitegen.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.4.01.6.02.3.0
console_log_handler^1.0.01.1.61.1.6
http_server^0.9.00.9.8+31.0.0
intl^0.15.00.15.80.17.0
logging>=0.11.3 <1.0.00.11.41.0.2
markdown^2.0.02.1.84.0.1
mustache^1.0.01.1.11.1.1
packages^0.4.00.4.40.4.4
path^1.0.01.8.01.8.0
system_info^0.1.00.1.31.0.1
validate^1.0.01.7.01.7.0
where^6.0.06.6.08.0.0
yaml^2.1.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
ansicolor-1.1.12.0.1
build_cli_annotations-1.2.02.0.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
file_utils-0.1.41.0.1
globbing-0.3.11.0.0
meta-1.7.01.7.0
mime-0.9.71.0.1
optional-3.1.06.1.0+1
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.4.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.9.0` on http_server does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http_server to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.