simple_animations 2.3.0-beta.4
simple_animations: ^2.3.0-beta.4 copied to clipboard

Powerful framework to create beautiful custom animations in no time.

1156
likes
80/ 130
pub points
98%
popularity

We analyzed this package on Oct 5, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/felixblaschke/simple_animations/blob/master/simple_animations was unreachable.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-19T12:09:06.710969] Starting...
Documenting simple_animations...

stderr: Unhandled exception:
fatal error: unable to locate the input directory at /tmp/tool-envHOBHDK/pub-cache-dirNSVDPC/hosted/pub.dartlang.org/sa_anicoto-1.3.1/lib.
#0      PubPackageMeta.fromDir (package:dartdoc/src/package_meta.dart:251:7)
#1      PubPackageMeta.fromFilename (package:dartdoc/src/package_meta.dart:236:27)
#2      PackageMetaProvider.fromFilename (package:dartdoc/src/package_meta.dart:73:54)
#3      PubPackageMetaProvider.fromFilename (package:pub_dartdoc/src/pub_hooks.dart:210:51)
#4      PubPackageBuilder._packageMetasForFiles (package:dartdoc/src/model/package_builder.dart:168:57)
#5      PubPackageBuilder._parseLibraries (package:dartdoc/src/model/package_builder.dart:225:17)
<asynchronous suspension>
#6      PubPackageBuilder.getLibraries (package:dartdoc/src/model/package_builder.dart:396:5)
<asynchronous suspension>
#7      PubPackageBuilder.buildPackageGraph (package:dartdoc/src/model/package_builder.dart:69:5)
<asynchronous suspension>
#8      Dartdoc.generateDocsBase (package:dartdoc/dartdoc.dart:202:24)
<asynchronous suspension>
#9      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:251:24)
<asynchronous suspension>
#10     main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
sa_anicoto^1.2.01.3.11.3.1
sa_liquid^0.0.1-beta.60.0.1-beta.61.1.0
sa_multi_tween^1.1.31.2.01.2.0
sa_stateless_animation^1.1.01.2.01.2.0
sa_v1_migration^1.1.21.1.21.1.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
supercharged-1.12.02.1.1
supercharged_dart-1.4.02.1.1
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.0.1-beta.6` on sa_liquid does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions sa_liquid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.2, Flutter 2.5.1, Dart 2.14.2.