simpay 0.2.3 copy "simpay: ^0.2.3" to clipboard
simpay: ^0.2.3 copied to clipboard

SDK para la integración con la API de Simpay

0
likes
50/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 50 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://www.simpay.cl was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 151 API elements (1.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: colors, colors.AppColor, colors.AppColor.AppColor, colors.AppColor.error, colors.AppColor.light.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:simpay/simpay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:simpay/simpay.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:simpay/simpay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:simpay/simpay.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:simpay/simpay.dart that imports:
  • package:simpay/webview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:simpay/simpay.dart that imports:
  • package:simpay/webview.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_android_cookie_manager.dart that declares support for platforms: Android.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

ERROR: The named parameter 'primary' isn't defined.

lib/webview.dart:241:39

    ╷
241 │                                       primary: AppColor.primary))),
    │                                       ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/webview.dart

WARNING: The value of the local variable 'payments' isn't used.

lib/simpay.dart:171:20

    ╷
171 │       ListPayments payments = ListPayments.fromJson(json.decode(res.body));
    │                    ^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/simpay.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.1 3.0.3 3.0.3
device_info ^2.0.2 2.0.3 2.0.3
flutter flutter 0.0.0 0.0.0
http ^0.13.1 0.13.6 1.2.1
socket_io_client ^1.0.2 1.0.2 2.0.3+1
webview_flutter ^2.1.1 2.8.0 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
device_info_platform_interface - 2.0.1 2.0.1
http_parser - 4.0.2 4.0.2
js - 0.6.7 0.7.1
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
socket_io_common - 1.0.1 2.0.3
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.16.0
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.13.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.13.1` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^1.0.2` on socket_io_client does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions socket_io_client to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
50
pub points
0%
popularity

Publisher

verified publisherbukitech.cl

SDK para la integración con la API de Simpay

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

crypto, device_info, flutter, http, socket_io_client, webview_flutter

More

Packages that depend on simpay