signalr_core 1.0.8
signalr_core: ^1.0.8 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

ASP.NET Core SignalR Client written for Dart that is platform-independent, and can be used on both the command-line and the browser.

48
likes
110 / 110
pub points
90 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 110 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 110 out of 271 API elements (40.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
equatable^1.2.31.2.61.2.6
http^0.12.10.12.20.13.0
logging^0.11.40.11.41.0.0
meta^1.1.81.2.41.3.0
sse_client^0.0.30.0.30.0.3
tuple^1.0.31.0.31.0.3
web_socket_channel^1.1.01.2.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0
charcode-1.1.31.2.0
collection-1.14.131.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
http_parser-3.1.44.0.0
matcher-0.12.90.12.10
path-1.7.01.8.0
quiver-2.1.53.0.0
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
stream_channel-2.0.02.1.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.2.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.12.1` on http does not support the stable version `0.13.0`, that was published 20 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.11.4` on logging does not support the stable version `1.0.0`, that was published 20 days ago.

When logging is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

48
likes
110
pub points
90%
popularity

Publisher

jamiewest.dev

ASP.NET Core SignalR Client written for Dart that is platform-independent, and can be used on both the command-line and the browser.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

equatable, http, logging, meta, sse_client, tuple, web_socket_channel

More

Packages that depend on signalr_core