shelf_oauth 0.8.2

shelf_oauth #

Build Status Pub Version

Provides Shelf Handlers to do the OAuth dance. Supports OAuth1 and OAuth2

Usage #


Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.8.1 #

  • upgraded crypto package to 0.9.2+1

0.8.1 #

  • increase upper bound on uri package

0.8.0 #

  • ClientFactory now returns a Future

0.7.0 #

  • Renamed OAuth2Provider to OAuth2AuthorizationServer and similar for oauth1
  • Added some common authorization servers like github, bitbucket, google and hipchat

0.6.0 #

  • shelf 0.6.0
  • OAuth2ProviderHandlers take factories for ClientId and OAuth2Provider
  • upgrade uri and test packages

0.5.0 #

  • Now uses http_exception package rather than shelf_exception_response

0.4.0 #

  • make accessType a parameter. Note: default is now 'online' whereas previously it was 'offline'

0.3.1 #

  • added OAuthStorage for conveniently grouping all oauth related storage

0.3.0 #

  • storing tokens in oauth 2 now optional
  • fixed handling of content-type
  • store context for oauth2

0.2.0 #

  • Slightly more robust handling of content-type

0.1.0 #

  • Added oauth2

0.0.2 #

  • some validation

0.0.1 #

  • Initial version, created by Stagehand.


// Copyright (c) 2014, <your name>. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

library shelf_oauth.example;

main() {}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  shelf_oauth: ^0.8.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:shelf_oauth/shelf_oauth.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0