oauth 0.4.0

  • README.md
  • Installing
  • Versions
  • 21

An implementation of OAuth 1.0a, as per RFC 5849.

The client portion is designed for use with the http package. The server portion is designed to work with the dart:io HttpServer class.

Supports HMAC-SHA1 and RSA-SHA1 signatures. HMAC-SHA1 is well tested, RSA-SHA1 is completely untested and experimental. PAINTEXT signatures are unsupported.

Comes with a test suite. Please report any incompatibility issues.

0.4.0 #

  • Use Random.secure() to generate random bytes
  • Updated to work with latest versions of packages like crypto
  • BREAKING: generateParameters now takes a http package Request object rather than a BaseRequest

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  oauth: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:oauth/oauth.dart';
Version Uploaded Documentation Archive
0.4.0 Jan 17, 2017 Go to the documentation of oauth 0.4.0 Download oauth 0.4.0 archive
0.3.0 Nov 7, 2014 Go to the documentation of oauth 0.3.0 Download oauth 0.3.0 archive
0.2.1 Aug 9, 2014 Go to the documentation of oauth 0.2.1 Download oauth 0.2.1 archive
0.2.0 May 9, 2014 Go to the documentation of oauth 0.2.0 Download oauth 0.2.0 archive
0.1.0 Apr 21, 2014 Go to the documentation of oauth 0.1.0 Download oauth 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0