http_exception 0.2.1

  • Readme
  • Changelog
  • Installing
  • 68

HTTP Exceptions #

Star this Repo Pub Package Build Status Coverage Status

A set of predefined exception classes for HTTP errors extracted from shelf_exception_response.

License #

Apache 2.0

0.2.1 #

  • toMap() should not throw when data is null

0.2.0 #

  • migrate to Dart 2
  • enable Travis CI
  • add badges

0.1.0 #

  • created this package consisting only of the exception classes from the shelf_exception_response package.

0.2.0 #

  • Dart 2 support

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  http_exception: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:http_exception/http_exception.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Maintenance suggestions

Package is getting outdated. (-46.30 points)

The package was last published 76 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and http_exception.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
grinder ^0.8.3
test ^1.3.0