rx_bloc_list 4.0.1 copy "rx_bloc_list: ^4.0.1" to clipboard
rx_bloc_list: ^4.0.1 copied to clipboard

The rx_bloc_list package facilitates implementing infinity scroll and pull-to-refresh features with minimal setup. This package is meant to be used along with RxBloc ecosystem.

13
likes
160/ 160
pub points
74%
popularity

We analyzed this package 4 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

60 out of 71 API elements (84.5 %) have documentation comments.

Some symbols that are missing documentation: models, rx_bloc_list, rx_bloc_list.Identifiable, rx_bloc_list.Identifiable.Identifiable, rx_bloc_list.Identifiable.isEqualToIdentifiable.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.1 1.18.0 1.19.0
flutter flutter 0.0.0 0.0.0
flutter_rx_bloc ^6.1.0 6.1.1 6.1.1
rx_bloc ^5.0.0 5.0.3 5.0.3
rxdart ^0.27.7 0.27.7 0.28.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
provider - 6.1.2 6.1.2
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.27.7` on rxdart does not support the stable version `0.28.0`, that was published 6 days ago.

When rxdart is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

13
likes
160
pub points
74%
popularity

Publisher

verified publisherprimeholding.com

The rx_bloc_list package facilitates implementing infinity scroll and pull-to-refresh features with minimal setup. This package is meant to be used along with RxBloc ecosystem.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter, flutter_rx_bloc, rx_bloc, rxdart

More

Packages that depend on rx_bloc_list