rw_git 1.0.3 copy "rw_git: ^1.0.3" to clipboard
rw_git: ^1.0.3 copied to clipboard

A git wrapper that facilitates the execution of various useful git commands.

2
likes
140/ 140
pub points
61%
popularity

We analyzed this package 14 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

11 out of 22 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: rw_git.RwGit, rw_git.RwGit.RwGit, rw_git.RwGit.gitRepoIndicator, rw_git.RwGit.invalidGitCommandResult, rw_git.RwGitParser.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:rw_git/rw_git.dart that imports:
  • package:rw_git/src/git_service/rw_git_base.dart that imports:
  • package:git/git.dart that imports:
  • package:git/src/tree_entry.dart that imports:
  • package:git/src/util.dart that imports:
  • package:git/src/top_level.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
git ^2.2.0 2.2.1 2.2.1
path ^1.8.0 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

2
likes
140
pub points
61%
popularity

Publisher

verified publisherpub.gbrandtio.dev

A git wrapper that facilitates the execution of various useful git commands.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

git, path

More

Packages that depend on rw_git