rw_blue_print_pos 0.0.65 copy "rw_blue_print_pos: ^0.0.65" to clipboard
rw_blue_print_pos: ^0.0.65 copied to clipboard

Plugin to connecting bluetooth printer device, support on Android and iOS

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: rw_blue_print_pos,
    • contains a version property, and,
    • does not contain a publish_to property.

Repository has no matching pubspec.yaml with name: rw_blue_print_pos.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

31 out of 108 API elements (28.7 %) have documentation comments.

Some symbols that are missing documentation: blue_device, blue_device.BlueDevice, blue_device.BlueDevice.BlueDevice, blue_device.BlueDevice.connected, blue_device.BlueDevice.type.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:rw_blue_print_pos/blue_print_pos.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:rw_blue_print_pos/blue_print_pos.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:rw_blue_print_pos/blue_print_pos.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:rw_blue_print_pos/blue_print_pos.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: The import of 'dart:typed_data' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/services.dart'.

lib/blue_print_pos.dart:3:8

  ╷
3 │ import 'dart:typed_data';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/blue_print_pos.dart

INFO: The import of 'package:rw_blue_print_pos/models/connection_status.dart' is unnecessary because all of the used elements are also provided by the import of 'package:rw_blue_print_pos/models/models.dart'.

lib/blue_print_pos.dart:6:8

  ╷
6 │ import 'package:rw_blue_print_pos/models/connection_status.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/blue_print_pos.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
blue_thermal_printer 1.2.0 1.2.0 1.2.3
esc_pos_utils_plus 2.0.1+6 2.0.1+6 2.0.3
flutter flutter 0.0.0 0.0.0
flutter_blue 0.8.0 0.8.0 0.8.0
image 3.1.1 3.1.1 4.1.7
qr_flutter ^4.0.0 4.1.0 4.1.0
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
csslib - 1.0.0 1.0.0
fixnum - 1.1.0 1.1.0
hex - 0.2.0 0.2.0
html - 0.15.4 0.15.4
js - 0.7.1 0.7.1
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
petitparser - 5.4.0 6.0.2
pointycastle - 3.9.0 3.9.0
protobuf - 2.1.0 3.1.0
qr - 3.0.1 3.0.1
rxdart - 0.26.0 0.27.7
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
xml - 5.4.1 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `1.2.0` on blue_thermal_printer does not support the stable version `1.2.1`.

Try running dart pub upgrade --major-versions blue_thermal_printer to update the constraint.

The constraint `2.0.1+6` on esc_pos_utils_plus does not support the stable version `2.0.2`.

Try running dart pub upgrade --major-versions esc_pos_utils_plus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

0
likes
100
pub points
0%
popularity

Publisher

unverified uploader

Plugin to connecting bluetooth printer device, support on Android and iOS

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

blue_thermal_printer, esc_pos_utils_plus, flutter, flutter_blue, image, qr_flutter

More

Packages that depend on rw_blue_print_pos