round_spot 0.5.0 copy "round_spot: ^0.5.0" to clipboard
round_spot: ^0.5.0 copied to clipboard

Customizable, easy to use heat map interface analysis library

86
likes
130/ 160
pub points
69%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

46 out of 46 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 13 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/widgets/detector.dart:177:28

    ╷
177 │     WidgetsBinding.instance!.addPostFrameCallback((_) {
    │                            ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/detector.dart

WARNING: This function has a nullable return type of 'Axis?', but ends without returning a value.

lib/src/widgets/detector.dart:202:9

    ╷
202 │   Axis? _getScrollAxis() {
    │         ^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/detector.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
enum_to_string ^2.0.1 2.0.1 2.0.1
equatable ^2.0.0 2.0.5 2.0.5
fixnum ^1.0.0 1.1.0 1.1.0
flutter flutter 0.0.0 0.0.0
get_it ^7.1.0 7.7.0 7.7.0
logging ^1.0.0 1.2.0 1.2.0
meta ^1.3.0 1.12.0 1.15.0
protobuf ^2.0.0 2.1.0 3.1.0
simple_cluster ^0.3.0 0.3.0 0.3.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on protobuf does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.