robusta_runner 0.2.0+1 copy "robusta_runner: ^0.2.0+1" to clipboard
robusta_runner: ^0.2.0+1 copied to clipboard

Run and extend your apps base on Riverpod, event driven, extensions, and more.

0
likes
150/ 160
pub points
4%
popularity

We analyzed this package 3 hours ago, and awarded it 150 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/covalab/robusta/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

66 out of 66 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:robusta_runner/robusta_runner.dart that imports:
  • package:robusta_runner/src/runner.dart that imports:
  • package:robusta_runner/src/provider.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/file_output_stub.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
logger ^1.2.0 1.4.0 2.4.0
meta ^1.8.0 1.15.0 1.15.0
riverpod ^2.2.0 2.5.1 2.5.1
robusta_events ^0.2.1 0.2.1 0.2.1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
path - 1.9.0 1.9.0
stack_trace - 1.11.1 1.11.1
state_notifier - 1.0.0 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

0
likes
150
pub points
4%
popularity

Publisher

unverified uploader

Run and extend your apps base on Riverpod, event driven, extensions, and more.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

logger, meta, riverpod, robusta_events

More

Packages that depend on robusta_runner