robusta_runner 0.2.0+1 copy "robusta_runner: ^0.2.0+1" to clipboard
robusta_runner: ^0.2.0+1 copied to clipboard

Run and extend your apps base on Riverpod, event driven, extensions, and more.

example/lib/main.dart

import 'package:robusta_runner/robusta_runner.dart';

Future<void> main() async {
  var counter = 0;

  final runner = Runner(
    extensions: [
      EventExtension(
        configurator: (eventManager, container) {
          eventManager.addEventListener<RunEvent>((_) => counter++);
        },
      ),
    ],
  );

  await runner.run();

  print(counter);
}
0
likes
150
pub points
4%
popularity

Publisher

unverified uploader

Run and extend your apps base on Riverpod, event driven, extensions, and more.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

logger, meta, riverpod, robusta_events

More

Packages that depend on robusta_runner