rive 0.0.1
rive: ^0.0.1 copied to clipboard

Placeholder for Flare.

552
likes
70/ 130
pub points
98%
popularity

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Did not run dartdoc

  • Package version is older than two years and has a newer release.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flare_flutter^1.7.31.8.33.0.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
flare_dart-2.3.42.3.4
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.7.3` on flare_flutter does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions flare_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

552
likes
70
pub points
98%
popularity

Publisher

rive.app

Placeholder for Flare.

Homepage

License

unknown (LICENSE)

Dependencies

flare_flutter, flutter

More

Packages that depend on rive