request_api_helper 3.0.2+2 icon indicating copy to clipboard operation
request_api_helper: ^3.0.2+2 copied to clipboard

integrating API will be faster and doesn't take long, just configure the initial settings and you can use this helper freely.

6
likes
120/ 130
pub points
61%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 64 out of 192 API elements (33.3 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:request_api_helper/request_api_helper.dart that imports:
  • package:request_api_helper/base_request.dart that imports:
  • package:request_api_helper/rest_api.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:request_api_helper/request_api_helper.dart that imports:
  • package:request_api_helper/base_request.dart that imports:
  • package:request_api_helper/rest_api.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:request_api_helper/request_api_helper.dart that imports:
  • package:request_api_helper/base_request.dart that imports:
  • package:request_api_helper/rest_api.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS, Web.
Package not compatible with platform Web

Because:

  • package:request_api_helper/request_api_helper.dart that imports:
  • package:request_api_helper/base_request.dart that imports:
  • package:request_api_helper/rest_api.dart that imports:
  • package:request_api_helper/model/config_model.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

lib/background.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/base_request.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
fluttertoast^8.0.88.0.88.0.8
http^0.13.40.13.40.13.4
http_parser^4.0.04.0.04.0.0
shared_preferences^2.0.82.0.122.0.12
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.4
meta-1.7.01.7.0
path-1.8.11.8.1
path_provider_linux-2.1.52.1.5
path_provider_platform_interface-2.0.32.0.3
path_provider_windows-2.0.52.0.5
platform-3.1.03.1.0
plugin_platform_interface-2.1.22.1.2
process-4.2.44.2.4
shared_preferences_android-2.0.102.0.10
shared_preferences_ios-2.0.92.0.9
shared_preferences_linux-2.0.42.0.4
shared_preferences_macos-2.0.22.0.2
shared_preferences_platform_interface-2.0.02.0.0
shared_preferences_web-2.0.32.0.3
shared_preferences_windows-2.0.42.0.4
sky_engine-0.0.990.0.99
source_span-1.8.21.8.2
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1
win32-2.3.82.3.8
xdg_directories-0.2.00.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.

6
likes
120
pub points
61%
popularity

integrating API will be faster and doesn't take long, just configure the initial settings and you can use this helper freely.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, fluttertoast, http, http_parser, shared_preferences

More

Packages that depend on request_api_helper