reloadly 1.0.5 copy "reloadly: ^1.0.5" to clipboard
reloadly: ^1.0.5 copied to clipboard

Reloadly Dart Sdk.It wraps the reloadly airtime sdk.Helps you generate tokens, get your balance and topup any number in the world.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://harambeeapps.co.ke was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 8 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: reloadly.Reloadly, reloadly.Reloadly.Reloadly, reloadly.Reloadly.getBalance, reloadly.Reloadly.getToken, reloadly.Reloadly.topUp.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

WARNING: The value of the local variable 'body' isn't used.

lib/src/reloadly_base.dart:54:9

   ╷
54 │     var body = {
   │         ^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/reloadly_base.dart

WARNING: Two keys in a map literal shouldn't be equal.

lib/src/reloadly_base.dart:62:7

   ╷
62 │       "countryCode":"CA",
   │       ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/reloadly_base.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.0 4.0.6 5.4.1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

0
likes
90
pub points
0%
popularity

Publisher

verified publisherharambeeapps.co.ke

Reloadly Dart Sdk.It wraps the reloadly airtime sdk.Helps you generate tokens, get your balance and topup any number in the world.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

dio

More

Packages that depend on reloadly