r_crypto 0.5.0 copy "r_crypto: ^0.5.0" to clipboard
r_crypto: ^0.5.0 copied to clipboard

Rust backend support crypto flutter library, much faster than Dart-implementation library, light-weight library. Some crypto support hardware accelerate.

9
likes
120/ 140
pub points
41%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

36 out of 38 API elements (94.7 %) have documentation comments.

Some symbols that are missing documentation: r_crypto, r_crypto.HashType.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Web`.

Because:

  • package:r_crypto/r_crypto.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/basic/loader.dart:42:11

   ╷
42 │       ptr.elementAt(i).value = list[i];
   │           ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/basic/loader.dart

INFO: 'elementAt' is deprecated and shouldn't be used. Use operator + instead.

lib/src/basic/loader.dart:50:27

   ╷
50 │       result[i] = pointer.elementAt(i).value;
   │                           ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/basic/loader.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.0.0 1.2.1 2.1.2
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

9
likes
120
pub points
41%
popularity

Publisher

verified publishertinocheng.app

Rust backend support crypto flutter library, much faster than Dart-implementation library, light-weight library. Some crypto support hardware accelerate.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, flutter

More

Packages that depend on r_crypto