qosic_dart 0.1.0+1 copy "qosic_dart: ^0.1.0+1" to clipboard
qosic_dart: ^0.1.0+1 copied to clipboard

A non-official package to use Qosic USSD's mobile money provider on your Dart and Flutter app

3
likes
95/ 140
pub points
21%
popularity

We analyzed this package 2 days ago, and awarded it 95 pub points (of a possible 140):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: qosic_dart,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository has no repository or homepage URL.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:7:43

  ╷
7 │ <p>This package is a simple way to handle <a href="http://qosic.com">Qosic</a>'s USSD payment. It allows you to integrate mobile money payment into your Dart and Flutter app.</p>
  │                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 25 API elements (76.0 %) have documentation comments.

Some symbols that are missing documentation: qosic_dart.QosicDart.dio, qosic_dart.QosicException, qosic_dart.QosicException.QosicException, qosic_dart.QosicException.data, qosic_dart.QosicException.msg.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: Unused import: 'dart:developer'.

lib/src/apis/apis.dart:1:8

  ╷
1 │ import 'dart:developer';
  │        ^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/apis/apis.dart

lib/src/helpers/constants.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
dio ^4.0.6 4.0.6 5.4.3+1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.6` on dio does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions dio to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

3
likes
95
pub points
21%
popularity

Publisher

verified publisherelikemmedehou.com

A non-official package to use Qosic USSD's mobile money provider on your Dart and Flutter app

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dio

More

Packages that depend on qosic_dart