pylons_sdk 0.1.4 copy "pylons_sdk: ^0.1.4" to clipboard
pylons_sdk: ^0.1.4 copied to clipboard

Pylons sdk connects client apps to the pylons wallet. It helps the client apps to perform actions on the pylons chain via wallet.

6
likes
100/ 140
pub points
0%
popularity

We analyzed this package 15 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4069 out of 6054 API elements (67.2 %) have documentation comments.

Some symbols that are missing documentation: low_level, low_level.AuthInfo, low_level.AuthInfo.$_whichOneof, low_level.AuthInfo.AuthInfo, low_level.AuthInfo.check.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:pylons_sdk/pylons_sdk.dart that imports:
  • package:pylons_sdk/src/pylons_wallet.dart that imports:
  • package:pylons_sdk/src/pylons_wallet/pylons_wallet_impl.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 182 issues. Showing the first 2:

WARNING: The value of the field '_native' isn't used.

lib/src/types/execution.dart:10:29

   ╷
10 │   final generated.Execution _native;
   │                             ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/types/execution.dart

INFO: The file name 'responseCompleters.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/features/ipc/responseCompleters.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
bitstream >=0.0.4 <2.0.0 1.1.0 1.1.0
dartz ^0.10.0 0.10.1 0.10.1
decimal ^2.1.0 2.3.3 2.3.3
equatable ^2.0.3 2.0.5 2.0.5
fixnum ^1.0.0 1.1.0 1.1.0
flutter flutter 0.0.0 0.0.0
protobuf ^2.0.0 2.1.0 3.1.0
uni_links ^0.5.1 0.5.1 0.5.1
uni_links_platform_interface ^1.0.0 1.0.0 1.0.0
url_launcher ^6.1.2 6.2.6 6.2.6
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
plugin_platform_interface - 2.1.8 2.1.8
rational - 2.2.2 2.2.2
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
uni_links_web - 0.1.0 0.1.0
url_launcher_android - 6.3.1 6.3.1
url_launcher_ios - 6.2.5 6.2.5
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.1.0 3.1.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on protobuf does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

6
likes
100
pub points
0%
popularity

Publisher

verified publisherpylons.tech

Pylons sdk connects client apps to the pylons wallet. It helps the client apps to perform actions on the pylons chain via wallet.

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

unknown (LICENSE)

Dependencies

bitstream, dartz, decimal, equatable, fixnum, flutter, protobuf, uni_links, uni_links_platform_interface, url_launcher

More

Packages that depend on pylons_sdk