puro 1.3.1 copy "puro: ^1.3.1" to clipboard
puro: ^1.3.1 copied to clipboard

A powerful tool for installing and upgrading Flutter versions

75
likes
130/ 160
pub points
38%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

594 out of 905 API elements (65.6 %) have documentation comments.

Some symbols that are missing documentation: cli, cli.main, models, models.CommandErrorModel, models.CommandErrorModel.$_whichOneof.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:puro/cli.dart that imports:
  • package:puro/src/cli.dart that imports:
  • package:puro/src/commands/repl.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `iOS`.

Because:

  • package:puro/cli.dart that imports:
  • package:puro/src/cli.dart that imports:
  • package:puro/src/commands/repl.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.
Package does not support platform `Web`.

Because:

  • package:puro/cli.dart that imports:
  • package:puro/src/cli.dart that imports:
  • package:puro/src/commands/repl.dart that imports:
  • package:dart_console/dart_console.dart that declares support for platforms: Windows, Linux, macOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Linux`.

Because:

  • package:puro/cli.dart that imports:
  • package:puro/src/cli.dart that imports:
  • package:puro/src/commands/repl.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:puro/cli.dart that imports:
  • package:puro/src/cli.dart that imports:
  • package:puro/src/commands/repl.dart that imports:
  • package:dart_console/dart_console.dart that imports:
  • package:dart_console/src/console.dart that imports:
  • package:dart_console/src/ffi/win/termlib_win.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

INFO: Statements in a while should be enclosed in a block.

lib/src/install/profile.dart:404:52

    ╷
404 │     while (paths.isNotEmpty && paths.last.isEmpty) paths.removeLast();
    │                                                    ^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/install/profile.dart

INFO: Statements in a while should be enclosed in a block.

lib/src/json_edit/editor.dart:60:65

   ╷
60 │     while (_validOffset(offset - 1) && !_newlineAt(offset - 1)) offset--;
   │                                                                 ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/json_edit/editor.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.4.0 5.13.0 6.7.0
args ^2.3.1 2.5.0 2.5.0
async ^2.9.0 2.11.0 2.11.0
clock ^1.1.1 1.1.1 1.1.1
collection ^1.17.0 1.19.0 1.19.0
dart_console ^1.1.2 1.2.0 4.1.0
file ^6.1.4 6.1.4 7.0.0
freezed_annotation ^2.1.0 2.4.1 2.4.1
http ^0.13.5 0.13.6 1.2.1
json_annotation ^4.7.0 4.9.0 4.9.0
meta ^1.8.0 1.15.0 1.15.0
mutex ^3.0.0 3.1.0 3.1.0
neoansi ^0.3.2+1 0.3.2+1 0.3.2+1
path ^1.8.2 1.9.0 1.9.0
petitparser ^5.1.0 5.4.0 6.0.2
process ^4.2.4 4.2.4 5.0.2
protobuf ^2.1.0 2.1.0 3.1.0
pub_semver ^2.1.1 2.1.4 2.1.4
rxdart ^0.27.5 0.27.7 0.28.0
stack_trace ^1.10.0 1.11.1 1.11.1
typed_data ^1.3.1 1.3.2 1.3.2
vm_service ^10.1.2 10.1.2 14.2.4
xml ^6.1.0 6.3.0 6.5.0
yaml ^3.1.1 3.1.2 3.1.2
yaml_edit ^2.0.3 2.2.1 2.2.1
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 72.0.0
characters - 1.3.0 1.3.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
http_parser - 4.1.0 4.1.0
intl - 0.18.1 0.19.0
neocolor - 0.1.0 0.1.0
package_config - 2.1.0 2.1.0
platform - 3.1.5 3.1.5
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
watcher - 1.1.0 1.1.0
win32 - 5.5.1 5.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 9 issues. Showing the first 2:

The constraint `^5.4.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.1.2` on dart_console does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions dart_console to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.