pulsar_iot_client 1.0.3 icon indicating copy to clipboard operation
pulsar_iot_client: ^1.0.3 copied to clipboard

Apache Pulsar IoT client

0
likes
90/ 130
pub points
10%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
10 / 20icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 52 out of 120 API elements (43.3 %) have documentation comments.
icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pulsar_iot_client/pulsar_iot_client.dart that imports:
  • package:pulsar_iot_client/src/client.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 41 issues. Showing the first 2:

lib/src/client.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/client/consumer.dart doesn't match the Dart formatter.

To format your files run: dart format .

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
convert^3.0.13.0.13.0.1
crclib^3.0.03.0.03.0.0
fixnum^1.0.01.0.01.0.0
logging^1.0.21.0.21.0.2
protobuf^2.0.12.0.12.0.1
tuple^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
matcher-0.12.110.12.11
meta-1.7.01.7.0
path-1.8.11.8.1
quiver-3.0.1+13.0.1+1
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.15.1.