pubspec_lock 2.0.1+1
pubspec_lock: ^2.0.1+1 copied to clipboard

Dart library to access and manipulate content of pubpec.lock files

2
likes
90 / 110
pub points
56 %
popularity

We analyzed this package on Apr 23, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 150 API elements (20.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: The diagnostic 'avoid_equals_and_hash_code_on_mutable_classes' doesn't need to be ignored here because it's already being ignored.

lib/src/package_dependency/git_package_dependency/git_package_dependency.g.dart:85:21

   ╷
85 │ // ignore_for_file: avoid_equals_and_hash_code_on_mutable_classes
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/package_dependency/git_package_dependency/git_package_dependency.g.dart

INFO: The diagnostic 'avoid_equals_and_hash_code_on_mutable_classes' doesn't need to be ignored here because it's already being ignored.

lib/src/package_dependency/hosted_package_dependency/hosted_package_dependency.g.dart:70:21

   ╷
70 │ // ignore_for_file: avoid_equals_and_hash_code_on_mutable_classes
   │                     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/package_dependency/hosted_package_dependency/hosted_package_dependency.g.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
functional_data^0.3.00.3.01.0.0
json2yaml^1.0.11.0.1+11.0.1+1
meta^1.1.81.3.01.3.0
sum_types^0.2.10.2.1+20.2.1+2
yaml^2.2.02.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
path-1.8.01.8.0
plain_optional-0.1.30.1.3
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.0` on functional_data does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions functional_data to update the constraint.

The constraint `^2.2.0` on yaml does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

2
likes
90
pub points
56%
popularity

Dart library to access and manipulate content of pubpec.lock files

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

alexei.sintotski@gmail.com

License

MIT (LICENSE)

Dependencies

functional_data, json2yaml, meta, sum_types, yaml

More

Packages that depend on pubspec_lock