pub_server 0.1.5
pub_server: ^0.1.5 copied to clipboard

discontinued

A Dart package containing re-usable components for making a pub package server.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add pub_server

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  pub_server: ^0.1.5

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:pub_server/repository.dart';
import 'package:pub_server/shelf_pubserver.dart';
17
likes
0
pub points
35%
popularity

A Dart package containing re-usable components for making a pub package server.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

kustermann@google.com
kevmoo@google.com

License

LICENSE

Dependencies

dart2_constant, http_parser, logging, mime, pub_semver, shelf, yaml

More

Packages that depend on pub_server