pty 0.1.1 copy "pty: ^0.1.1" to clipboard
pty: ^0.1.1 copied to clipboard

Pty for Dart and Flutter. Provides the ability to create processes with pseudo terminal file descriptors.

7
likes
100/ 140
pub points
54%
popularity

We analyzed this package 2 days ago, and awarded it 100 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 8 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: pty, pty.PseudoTerminal, pty.PseudoTerminal.exitCode, pty.PseudoTerminal.kill, pty.PseudoTerminal.out.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:pty/pty.dart that imports:
  • package:pty/src/pty.dart that imports:
  • package:pty/src/impl/windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:pty/pty.dart that imports:
  • package:pty/src/pty.dart that imports:
  • package:pty/src/impl/windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Linux`.

Because:

  • package:pty/pty.dart that imports:
  • package:pty/src/pty.dart that imports:
  • package:pty/src/impl/windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `macOS`.

Because:

  • package:pty/pty.dart that imports:
  • package:pty/src/pty.dart that imports:
  • package:pty/src/impl/windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
Package does not support platform `Web`.

Because:

  • package:pty/pty.dart that imports:
  • package:pty/src/pty.dart that imports:
  • package:pty/src/impl/windows.dart that imports:
  • package:win32/win32.dart that declares support for platforms: Windows.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 254 issues. Showing the first 2:

WARNING: This API is available since SDK 2.16.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/impl/windows.dart:68:39

   ╷
68 │     final inputWriteSide = hWritePipe.value;
   │                                       ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/impl/windows.dart

WARNING: This API is available since SDK 2.16.0, but constraints '>=2.12.0 <3.0.0' don't guarantee it.

lib/src/impl/windows.dart:69:37

   ╷
69 │     final inputReadSide = hReadPipe.value;
   │                                     ^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/impl/windows.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.0.0 1.2.1 2.1.2
win32 ^2.0.0 2.6.1 5.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

The constraint `^2.0.0` on win32 does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions win32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

7
likes
100
pub points
54%
popularity

Publisher

unverified uploader

Pty for Dart and Flutter. Provides the ability to create processes with pseudo terminal file descriptors.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, win32

More

Packages that depend on pty