pty 0.2.2-pre copy "pty: ^0.2.2-pre" to clipboard
pty: ^0.2.2-pre copied to clipboard

PlatformWindows
outdated

Pty for Dart and Flutter. Provides the ability to create processes with pseudo terminal file descriptors.

pty #

GitHub repo size GitHub issues GitHub pull requests

Pty for Dart and Flutter. Provides the ability to create processes with pseudo terminal file descriptors.

Status #

test

Platform JIT(Debug) AOT(Release)
Windows Crash Works
Linux x64 Works Works
Linux x86 Not tested Not tested
macOS Works Works

Usage #

A simple usage example:

import 'package:pty/pty.dart';

void main() async {
  final pty = PseudoTerminal.start('bash', []);

  pty.write('ls\n');

  pty.out.listen((data) {
    print(data);
  });

  print(await pty.exitCode);
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

License #

This project is licensed under an MIT license.

7
likes
100
pub points
49%
popularity

Publisher

unverified uploader

Pty for Dart and Flutter. Provides the ability to create processes with pseudo terminal file descriptors.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi, win32

More

Packages that depend on pty