prestashop_webservice 0.6.0 copy "prestashop_webservice: ^0.6.0" to clipboard
prestashop_webservice: ^0.6.0 copied to clipboard

A dart package for reading data from prestashop webservices

1
likes
130/ 140
pub points
46%
popularity

We analyzed this package 15 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

61 out of 257 API elements (23.7 %) have documentation comments.

Some symbols that are missing documentation: prestashop_webservice.Associations, prestashop_webservice.Associations.Associations, prestashop_webservice.Associations.Associations.fromJson, prestashop_webservice.Associations.orderRows, prestashop_webservice.Associations.toJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
equatable ^2.0.5 2.0.5 2.0.5
http ^1.1.0 1.2.1 1.2.1
json_annotation ^4.8.1 4.8.1 4.8.1
loggy ^2.0.3 2.0.3 2.0.3
quiver ^3.2.1 3.2.1 3.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
matcher - 0.12.16+1 0.12.16+1
meta - 1.12.0 1.12.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.0 0.7.0
typed_data - 1.3.2 1.3.2
web - 0.5.0 0.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

1
likes
130
pub points
46%
popularity

Publisher

verified publishermsiviero.dev

A dart package for reading data from prestashop webservices

Repository (GitHub)
View/report issues

Topics

#api #prestashop #ecommerce

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

equatable, http, json_annotation, loggy, quiver

More

Packages that depend on prestashop_webservice