polar 7.2.0 copy "polar: ^7.2.0" to clipboard
polar: ^7.2.0 copied to clipboard

This is a Dart plugin wrapper for the Polar SDK on Android and iOS

17
likes
140/ 140
pub points
83%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

167 out of 168 API elements (99.4 %) have documentation comments.

Some symbols that are missing documentation: polar.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:polar/polar.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:polar/polar.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:polar/polar.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:polar/polar.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:polar/polar.dart that imports:
  • package:polar/src/polar_base.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
Package does not support platform `iOS`.

Because:

  • package:polar/polar.dart that imports:
  • package:polar/src/polar_base.dart that imports:
  • package:device_info_plus/device_info_plus.dart that imports:
  • package:device_info_plus/src/device_info_plus_windows.dart that imports:
  • package:win32_registry/win32_registry.dart that declares support for platforms: Windows.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
device_info_plus ^10.0.1 10.1.0 10.1.0
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.5 2.0.19 2.0.19
json_annotation ^4.8.1 4.8.1 4.8.1
permission_handler ^11.0.0 11.3.1 11.3.1
recase ^4.0.0 4.1.0 4.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
device_info_plus_platform_interface - 7.0.0 7.0.0
ffi - 2.1.2 2.1.2
file - 7.0.0 7.0.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
path - 1.9.0 1.9.0
permission_handler_android - 12.0.5 12.0.5
permission_handler_apple - 9.4.4 9.4.4
permission_handler_html - 0.1.1 0.1.1
permission_handler_platform_interface - 4.2.1 4.2.1
permission_handler_windows - 0.2.1 0.2.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1
win32 - 5.4.0 5.4.0
win32_registry - 1.1.3 1.1.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.