pmvvm 4.0.1 copy "pmvvm: ^4.0.1" to clipboard
pmvvm: ^4.0.1 copied to clipboard

A clean & simple MVVM solution for state management using Provider package.

71
likes
120/ 140
pub points
80%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

283 out of 343 API elements (82.5 %) have documentation comments.

Some symbols that are missing documentation: hook.view, hook.view.HookView.reactive, hook.view.HookView.render, index, index.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: Use the generic function type syntax in 'typedef's.

lib/models/observable.model.dart:5:14

  ╷
5 │ typedef void ValueChangedCallback<T>(
  │              ^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/observable.model.dart

lib/extensions/index.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_hooks ^0.18.3 0.18.6 0.20.5
provider ^6.0.2 6.1.2 6.1.2
tint ^2.0.0 2.0.1 2.0.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
nested - 1.0.0 1.0.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.3` on flutter_hooks does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions flutter_hooks to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

71
likes
120
pub points
80%
popularity

Publisher

unverified uploader

A clean & simple MVVM solution for state management using Provider package.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_hooks, provider, tint

More

Packages that depend on pmvvm