plurdart 0.1.56 icon indicating copy to clipboard operation
plurdart: ^0.1.56 copied to clipboard

A dart lib for Plurk APIs.

1
likes
80/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 1488 API elements (0.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:plurdart/plurdart.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 134 issues. Showing the first 2:

INFO: Unused import: 'package:meta/meta.dart'.

lib/src/models/rest/qry/lang_qry.dart:1:8

  ╷
1 │ import 'package:meta/meta.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/rest/qry/lang_qry.dart

INFO: Unused import: 'package:plurdart/src/models/rest/enums.dart'.

lib/src/models/rest/req/blocks_get.dart:1:8

  ╷
1 │ import 'package:plurdart/src/models/rest/enums.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models/rest/req/blocks_get.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
enum_to_string^2.0.12.0.12.0.1
flutterflutter0.0.00.0.0
http^0.13.40.13.50.13.5
intl^0.17.00.17.00.17.0
meta^1.7.01.8.01.8.0
oauth1^2.0.02.0.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
characters-1.2.11.2.1
clock-1.1.11.1.1
collection-1.16.01.17.0
crypto-3.0.23.0.2
http_parser-4.0.24.0.2
material_color_utilities-0.1.50.2.0
path-1.8.21.8.2
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.22.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.