plaid 1.0.2
plaid: ^1.0.2 copied to clipboard

Porting of Plaid Api (https://plaid.com/docs/) to Flutter.

2
likes
50 / 110
pub points
58 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 52 API elements (1.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:plaid/plaid.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/plaid.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.0+20.12.20.13.1
webview_flutter^0.3.7+10.3.242.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.3.7+1` on webview_flutter does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

2
likes
50
pub points
58%
popularity

Porting of Plaid Api (https://plaid.com/docs/) to Flutter.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

brian.ja.schardt@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, http, webview_flutter

More

Packages that depend on plaid