plaid 1.0.2

  • Readme
  • Changelog
  • Installing
  • 83

Flutter for Plaid Link

based off of: https://pub.dev/packages/flutter_plaid But provides additional necessary functionality pub

Usage #

class _Example extends State {
  
  showPlaidView() {
    bool plaidSandbox = false;
    
    Configuration configuration = Configuration(
        plaidPublicKey: 'yourPublicKey',
        plaidBaseUrl: 'https://cdn.plaid.com/link/v2/stable/link.html',
        plaidEnvironment: plaidSandbox ? 'sandbox' : 'production',
        environmentPlaidPathAccessToken:
            'https://sandbox.plaid.com/item/public_token/exchange',
        environmentPlaidPathStripeToken:
            'https://sandbox.plaid.com/processor/stripe/bank_account_token/create',
        plaidClientId: 'yourPlaidClientId',
        secret: plaidSandbox ? 'yourSecret' : '',
        clientName: 'ClientName',
        webhook: 'Webhook Url',
        products: 'auth,income',
        selectAccount: 'false'
        );

    FlutterPlaidApi flutterPlaidApi = FlutterPlaidApi(configuration);
    flutterPlaidApi.launch(context, (Result result) {
      ///handle result
    }, stripeToken: true);
  }

  @override
  Widget build(BuildContext context) {
    return Container();
  }
}

0.0.1 #

  • initial release.

0.0.2 #

  • Added configuration options

0.0.3 #

  • Added clientName option to config

0.0.4 #

  • Added clientName option to config

1.0.0 #

  • made default product: auth

1.0.1 #

  • updated readme

1.0.2 #

  • return more typed info on plaid loggin like instiution name, etc.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  plaid: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:plaid/plaid.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
71
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
88
Overall:
Weighted score of the above. [more]
83
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:plaid/plaid.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:plaid/plaid.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:plaid/plaid.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:plaid/plaid.dart that imports:
  • package:webview_flutter/webview_flutter.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • plaid that is a package requiring null.

Health issues and suggestions

Document public APIs. (-0.43 points)

51 out of 52 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/plaid.dart.

Run flutter format to format lib/plaid.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and plaid.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

The package description is too short. (-2 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
http ^0.12.0+2 0.12.1
webview_flutter ^0.3.7+1 0.3.22+1
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
http_parser 3.1.4
meta 1.1.8 1.2.1
path 1.7.0
pedantic 1.9.0 1.9.1
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test