pip_services3_rpc 1.0.8
pip_services3_rpc: ^1.0.8 copied to clipboard

This framework is a part of the [Pip.Services] project. It provides the following synchronous communication components over HTTP RPC

0
likes
75 / 110
pub points
20 %
popularity

We analyzed this package on Apr 17, 2021, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:2:33

  ╷
2 │ <p>This module is a part of the <a href="http://pipservices.org">Pip.Services</a> polyglot microservices toolkit.</p>
  │                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 134 out of 246 API elements (54.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pip_services3_rpc/pip_services3_rpc.dart that imports:
  • package:pip_services3_rpc/src/build/build.dart that imports:
  • package:pip_services3_rpc/src/build/DefaultRpcFactory.dart that imports:
  • package:pip_services3_rpc/src/services/StatusRestService.dart that imports:
  • package:pip_services3_rpc/src/services/RestService.dart that imports:
  • package:pip_services3_rpc/src/services/HttpResponseSender.dart that imports:
  • package:pip_services3_commons/pip_services3_commons.dart that imports:
  • package:pip_services3_commons/src/validate/validate.dart that imports:
  • package:pip_services3_commons/src/validate/ProjectionParamsSchema.dart that imports:
  • package:pip_services3_commons/src/validate/ArraySchema.dart that imports:
  • package:pip_services3_commons/src/reflect/ObjectReader.dart that imports:
  • package:pip_services3_commons/src/reflect/PropertyReflector.dart that imports:
  • dart:mirrors
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Unnecessary cast.

lib/src/services/CommandableSwaggerDocument.dart:137:14

    ╷
137 │         if ((value as List).isNotEmpty) {
    │              ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/services/CommandableSwaggerDocument.dart

INFO: Unnecessary cast.

lib/src/services/CommandableSwaggerDocument.dart:140:25

    ╷
140 │             var item = (value as List)[index];
    │                         ^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/services/CommandableSwaggerDocument.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.1.12.1.12.1.1
http^0.12.00.12.20.13.1
pip_services3_commons>=1.0.12 <2.0.01.0.121.0.12
pip_services3_components>=1.0.2 <2.0.01.0.61.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
charcode-1.2.01.2.0
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
http2-1.0.12.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+31.0.0
intl-0.17.00.17.0
logging-0.11.41.0.1
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
meta-1.3.01.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
mustache4dart2-0.1.00.1.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
quiver-2.1.53.0.1
quiver_hashcode-2.0.03.0.0+1
recase-2.0.13.0.1
source_span-1.8.11.8.1
sprintf-4.1.06.0.0
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
75
pub points
20%
popularity

Publisher

entinco.com

This framework is a part of the [Pip.Services] project. It provides the following synchronous communication components over HTTP RPC

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, http, pip_services3_commons, pip_services3_components

More

Packages that depend on pip_services3_rpc