pihole_api 0.3.1 icon indicating copy to clipboard operation
pihole_api: ^0.3.1 copied to clipboard

Provides models and endpoint wrappers for the Pi-hole API (summary, queries, versions etc.).

0
likes
120/ 140
pub points
29%
popularity

We analyzed this package 5 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...
MSG : Logs written to /tmp/tool-envSBGWWF/pub-cache-dirXFOROD/log/pub_log.txt.

stderr: FINE: Pub 2.19.1
SLVR: fact: pihole_api is 0.3.1
SLVR: derived: pihole_api
SLVR: fact: pihole_api requires the Flutter SDK
SLVR: conflict: pihole_api requires the Flutter SDK
SLVR: Version solving took 0:00:00.047034 seconds.
    | Tried 1 solutions.
FINE: Resolving dependencies finished (0.082s).
ERR : Because pihole_api requires the Flutter SDK, version solving failed.
    | 
    | Flutter users should run `flutter pub get` instead of `dart pub get`.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 311:5     VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 132:27    VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 96:11     VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                           Future.catchError
    | package:pub/src/utils.dart 111:52                    captureErrors.wrappedCallback
    | package:stack_trace                                  Chain.capture
    | package:pub/src/utils.dart 124:11                    captureErrors
[...]
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 311:5     VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 132:27    VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 96:11     VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                           Future.catchError
    | package:pub/src/utils.dart 111:52                    captureErrors.wrappedCallback
    | package:stack_trace                                  Chain.capture
    | package:pub/src/utils.dart 124:11                    captureErrors
    | package:pub/src/command.dart 190:13                  PubCommand.run
    | package:args/command_runner.dart 212:27              CommandRunner.runCommand
    | package:dartdev/dartdev.dart 241:30                  DartdevRunner.runCommand
    | package:args/command_runner.dart 122:25              CommandRunner.run.<fn>
    | dart:async                                           new Future.sync
    | package:args/command_runner.dart 122:14              CommandRunner.run
    | package:dartdev/dartdev.dart 65:31                   runDartdev
    | /b/s/w/ir/x/w/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
---- End log transcript ----
IO  : Writing 3000 characters to text file /tmp/tool-envSBGWWF/pub-cache-dirXFOR[...]

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 56 issues. Showing the first 2:

INFO: The annotation 'JsonKey' can only be used on fields or getters.

lib/src/models.dart:17:6

   ╷
17 │     @JsonKey(fromJson: numFromJson, name: 'domains_being_blocked')
   │      ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models.dart

INFO: The annotation 'JsonKey' can only be used on fields or getters.

lib/src/models.dart:20:6

   ╷
20 │     @JsonKey(fromJson: numFromJson, name: 'dns_queries_today')
   │      ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/models.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
clock>=1.1.0 <2.0.01.1.11.1.1
dio>=4.0.4 <5.0.04.0.64.0.6
freezed_annotation>=2.2.0 <2.3.02.2.02.2.0
html>=0.15.0 <1.0.00.15.10.15.1
http_mock_adapter>=0.3.2 <1.0.00.3.30.3.3
json_annotation>=4.7.0 <5.0.04.8.04.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.17.11.17.1
csslib-0.17.20.17.2
http_parser-4.0.24.0.2
meta-1.9.01.9.0
path-1.8.31.8.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.1.

0
likes
120
pub points
29%
popularity

Publisher

verified publisher icontster.nl

Provides models and endpoint wrappers for the Pi-hole API (summary, queries, versions etc.).

Repository (GitHub)

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

clock, dio, freezed_annotation, html, http_mock_adapter, json_annotation

More

Packages that depend on pihole_api