pigeon 0.3.0
pigeon: ^0.3.0 copied to clipboard

Code generator tool to make communication between Flutter and the host platform type-safe and easier.

266
likes
120 / 130
pub points
86 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 181 out of 194 API elements (93.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pigeon/pigeon.dart that imports:
  • package:pigeon/pigeon_lib.dart that imports:
  • package:pigeon/objc_generator.dart that imports:
  • package:pigeon/generator_tools.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^1.2.01.7.22.0.0
args^2.0.02.2.02.2.0
path^1.8.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.023.0.0
async-2.8.12.8.1
charcode-1.3.11.3.1
cli_util-0.3.30.3.3
collection-1.15.01.15.0
convert-3.0.13.0.1
crypto-3.0.13.0.1
file-6.1.26.1.2
glob-2.0.12.0.1
meta-1.7.01.7.0
package_config-2.0.02.0.0
pedantic-1.11.11.11.1
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.2.0` on analyzer does not support the stable version `2.0.0`, that was published 20 days ago.

When analyzer is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Dart 2.13.4.

266
likes
120
pub points
86%
popularity

Publisher

flutter.dev

Code generator tool to make communication between Flutter and the host platform type-safe and easier.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

analyzer, args, path

More

Packages that depend on pigeon