pfile 2.2.0 icon indicating copy to clipboard operation
pfile: ^2.2.0 copied to clipboard

A flutter project for working with files/binary data in a cross-platform way

0
likes
30/ 130
pub points
44%
popularity

We analyzed this package 23 hours ago, and awarded it 30 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +94 ms] executing: uname -m
[  +42 ms] Exit code 0 from: uname -m
[        ] x86_64
[   +7 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +6 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[        ] 676cefaaff197f27424942307668886253e1ec35
[   +2 ms] executing: [/tool/stable/flutter/] git tag --points-at 676cefaaff197f27424942307668886253e1ec35
[  +17 ms] Exit code 0 from: git tag --points-at 676cefaaff197f27424942307668886253e1ec35
[        ] 3.0.3
[  +11 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbolic @{u}
[   +5 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{u}
[        ] fatal: HEAD does not point to a branch
[  +68 ms] Unable to locate an Android SDK.
[   +4 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[   +5 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[  +78 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'LinuxEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'LinuxFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'MacOSFuchsiaSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerSDKArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterRunnerDebugSymbols' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[  +55 ms] executing: /tool/stable/flutter/bin/cache/dart-sdk/bin/dart __deprecated_pub upgrade --verbose
MSG : Resolving dependencies...
MSG : Logs written to /tmp/tool-envKYDJOJ/pub-cache-dirABKZJD/log/pub_log.txt.
[+2295 ms] "flutter pub" took 2,458ms.
[   +3 ms] Running shutdown hooks
[        ] Shutdown hooks complete
[   +1 ms] exiting with code 66

stderr: FINE: Pub 2.17.5
WARN: Warning: pubspec.yaml has overrides from pubspec_overrides.yaml
SLVR: fact: pfile is 2.2.0
SLVR: derived: pfile
SLVR: fact: pfile depends on buffer ^1.1.1
SLVR: fact: pfile depends on chunked_stream ^1.4.1
SLVR: fact: pfile depends on dartx ^0.7.1
SLVR: fact: pfile depends on flutter from sdk
SLVR: fact: pfile depends on logging ^1.0.2
SLVR: fact: pfile depends on path_provider ^2.0.1
SLVR: fact: pfile depends on uuid ^3.0.4
SLVR: fact: pfile depends on dartxx from path
SLVR:   selecting pfile
SLVR:   derived: dartxx from path
SLVR:   derived: uuid ^3.0.4
SLVR:   derived: path_provider ^2.0.1
SLVR:   derived: logging ^1.0.2
SLVR:   derived: flutter from sdk
SLVR:   derived: dartx ^0.7.1
SLVR:   derived: chunked_stream ^1.4.1
[...]
           <asynchronous suspension>
           #4      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #5      CommandRunner.runCommand (package:args/command_runner.dart:209:13)
           <asynchronous suspension>
           #6      FlutterCommandRunner.runCommand.<anonymous closure> (package:flutter_tools/src/runner/flutter_command_runner.dart:281:9)
           <asynchronous suspension>
           #7      AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #8      FlutterCommandRunner.runCommand (package:flutter_tools/src/runner/flutter_command_runner.dart:229:5)
           <asynchronous suspension>
           #9      run.<anonymous closure>.<anonymous closure> (package:flutter_tools/runner.dart:62:9)
           <asynchronous suspension>
           #10     AppContext.run.<anonymous closure> (package:flutter_tools/src/base/context.dart:150:19)
           <asynchronous suspension>
           #11     main (package:flutter_tools/executable.dart:94:3)
           <asynchronous suspension>



icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 30 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:logging/logging.dart'.

lib/native/pfile_native.dart:5:8

  ╷
5 │ import 'package:logging/logging.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/native/pfile_native.dart

ERROR: Target of URI doesn't exist: 'package:path_provider/path_provider.dart'.

lib/native/pfile_native.dart:6:8

  ╷
6 │ import 'package:path_provider/path_provider.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/native/pfile_native.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run flutter pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Warning: pubspec.yaml has overrides from pubspec_overrides.yaml
Because pfile depends on dartxx from path which doesn't exist (could not find package dartxx at "../dartxx"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

0
likes
30
pub points
44%
popularity

Publisher

unverified uploader

A flutter project for working with files/binary data in a cross-platform way

Repository (GitHub)
View/report issues

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

buffer, chunked_stream, dartx, flutter, logging, path_provider, uuid

More

Packages that depend on pfile