peru_consultas 0.0.1
peru_consultas: ^0.0.1 copied to clipboard

Plugin que permite realizar consultas a diversos servicios en Perú.

0
likes
70 / 130
pub points
0 %
popularity

We analyzed this package on Jul 29, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 8 API elements (12.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:peru_consultas/peru_consultas.dart that imports:
  • package:peru_consultas/src/sunat.dart that imports:
  • package:cookie_jar/cookie_jar.dart that imports:
  • package:cookie_jar/src/serializable_cookie.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cookie_jar^1.0.01.0.13.0.1
html^0.14.0+20.14.0+40.15.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
csslib-0.16.20.17.0
path-1.8.01.8.0
source_span-1.8.11.8.1
term_glyph-1.2.01.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on cookie_jar does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cookie_jar to update the constraint.

The constraint `^0.14.0+2` on html does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions html to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Dart 2.13.4.

0
likes
70
pub points
0%
popularity

Plugin que permite realizar consultas a diversos servicios en Perú.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

cookie_jar, html

More

Packages that depend on peru_consultas