pdf 3.10.8 copy "pdf: ^3.10.8" to clipboard
pdf: ^3.10.8 copied to clipboard

A pdf producer for Dart. It can create pdf files for both web or flutter.

2521
likes
140/ 140
pub points
99%
popularity

We analyzed this package 22 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

1051 out of 2840 API elements (37.0 %) have documentation comments.

Some symbols that are missing documentation: pdf, pdf.PdfAnnot, pdf.PdfAnnot.PdfAnnot, pdf.PdfAnnot.debugFill, pdf.PdfAnnot.elapsedStopwatch.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
archive ^3.1.0 3.6.0 3.6.0
barcode >=2.2.3 <3.0.0 2.2.8 2.2.8
bidi ^2.0.10 2.0.10 2.0.10
crypto ^3.0.0 3.0.3 3.0.3
image ^4.0.0 4.2.0 4.2.0
meta >=1.3.0 <2.0.0 1.15.0 1.15.0
path_parsing >=0.2.0 <2.0.0 1.0.1 1.0.1
vector_math ^2.1.0 2.1.4 2.1.4
xml >=6.3.0 <7.0.0 6.5.0 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
qr - 3.0.1 3.0.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

2521
likes
140
pub points
99%
popularity
screenshot

Publisher

verified publishernfet.net

A pdf producer for Dart. It can create pdf files for both web or flutter.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#pdf #printer #print #printing #report

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

archive, barcode, bidi, crypto, image, meta, path_parsing, vector_math, xml

More

Packages that depend on pdf