payu_payment 0.0.3 copy "payu_payment: ^0.0.3" to clipboard
payu_payment: ^0.0.3 copied to clipboard

Simple PayU integration using WebView. Flexible and easy to set up.

15
likes
120/ 140
pub points
41%
popularity

We analyzed this package 6 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

181 out of 252 API elements (71.8 %) have documentation comments.

Some symbols that are missing documentation: payu_auth, payu_auth.PayUAuthResponse, payu_auth.PayUAuthResponse.accessToken, payu_auth.PayUAuthResponse.expiresIn, payu_auth.PayUAuthResponse.PayUAuthResponse.fromJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:payu_payment/payu_payment.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:payu_payment/payu_payment.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:payu_payment/payu_payment.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:payu_payment/payu_payment.dart that declares support for platforms: Android, iOS.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform `Android`.

Because:

  • package:payu_payment/payu_payment.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_wkwebview/webview_flutter_wkwebview.dart that declares support for platforms: iOS.
Package does not support platform `iOS`.

Because:

  • package:payu_payment/payu_payment.dart that imports:
  • package:webview_flutter/webview_flutter.dart that imports:
  • package:webview_flutter/src/webview.dart that imports:
  • package:webview_flutter_android/webview_android_cookie_manager.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The import of 'package:webview_flutter/webview_flutter.dart' is unnecessary because all of the used elements are also provided by the import of 'package:payu_payment/payu_payment.dart'.

lib/payu_webview.dart:5:8

  ╷
5 │ import 'package:webview_flutter/webview_flutter.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/payu_webview.dart

INFO: Statements in an if should be enclosed in a block.

lib/service/payu_http_service.dart:23:7

   ╷
23 │       throw Exception('http.post error: statusCode= ${res.statusCode}');
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/service/payu_http_service.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.1 0.13.6 1.2.1
webview_flutter ^2.0.4 2.8.0 4.7.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4
webview_flutter_android - 2.10.4 3.16.1
webview_flutter_platform_interface - 1.9.5 2.10.0
webview_flutter_wkwebview - 2.9.5 3.13.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.1` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^2.0.4` on webview_flutter does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

15
likes
120
pub points
41%
popularity

Publisher

verified publisherlukeurban.tech

Simple PayU integration using WebView. Flexible and easy to set up.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, http, webview_flutter

More

Packages that depend on payu_payment