payhere_mobilesdk_flutter 3.0.8 copy "payhere_mobilesdk_flutter: ^3.0.8" to clipboard
payhere_mobilesdk_flutter: ^3.0.8 copied to clipboard

Make Onetime, Subscription and Pre-approval payments with your Flutter Mobile App through PayHere!

27
likes
40/ 140
pub points
89%
popularity

We analyzed this package 6 days ago, and awarded it 40 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The current Dart SDK version is 3.3.3.
Because payhere_mobilesdk_flutter requires SDK version >=2.12.0 <=3.1.1, version solving failed.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.3.3. Cannot run `flutter pub outdated`.

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.12.0 <=3.1.1"  #">=2.12.0 <=3.0.5"
  │        ^^^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.3.3.

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.12.0 <=3.1.1"  #">=2.12.0 <=3.0.5"
  │        ^^^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.3.3)

pubspec.yaml:9:8

  ╷
9 │   sdk: ">=2.12.0 <=3.1.1"  #">=2.12.0 <=3.0.5"
  │        ^^^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

27
likes
40
pub points
89%
popularity

Publisher

verified publisherpayhere.lk

Make Onetime, Subscription and Pre-approval payments with your Flutter Mobile App through PayHere!

Repository (GitHub)
View/report issues

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on payhere_mobilesdk_flutter