paulonia_repository 0.3.0
paulonia_repository: ^0.3.0 copied to clipboard

Package with abstract class for create Models and Repositories

1
likes
110 / 130
pub points
53 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: Documenting paulonia_repository...
Initialized dartdoc with 730 libraries in 116.7 seconds
Generating docs for library constants from package:paulonia_repository/constants.dart...
Generating docs for library RepoUpdate from package:paulonia_repository/RepoUpdate.dart...
Generating docs for library paulonia_repository from package:paulonia_repository/PauloniaRepository.dart...
Generating docs for library paulonia_repository from package:paulonia_repository/PauloniaModel.dart...
Documented 4 public libraries in 0.8 seconds
stderr:   warning: paulonia_repository has no library level documentation comments
    from paulonia_repository: (file:///tmp/pub-dartlang-dartdocNNDXIB/pkg/lib/PauloniaRepository.dart:1:9)
  warning: unresolved doc reference [_update()]
    from paulonia_repository.PauloniaRepository.getFromId: (file:///tmp/pub-dartlang-dartdocNNDXIB/pkg/lib/PauloniaRepository.dart:62:18)
  warning: unresolved doc reference [FirestoreConstants.ARRAY_QUERIES_ITEM_LIMIT]
    from paulonia_repository.PauloniaRepository.getFromIdList: (file:///tmp/pub-dartlang-dartdocNNDXIB/pkg/lib/PauloniaRepository.dart:96:23)
  warning: unresolved doc reference [_update()]
    from paulonia_repository.PauloniaRepository.getFromIdList: (file:///tmp/pub-dartlang-dartdocNNDXIB/pkg/lib/PauloniaRepository.dart:96:23)
  warning: paulonia_repository has no library level documentation comments
    from paulonia_repository: (file:///tmp/pub-dartlang-dartdocNNDXIB/pkg/lib/PauloniaModel.dart:1:9)
  error: failed to write file at: paulonia_repository/paulonia_repository-library.html
    for symbol paulonia_repository: (file:///tmp/pub-dartlang-dartdocNNDXIB/pkg/lib/PauloniaModel.dart:1:9)
    conflicting with file already generated by paulonia_repository: (file:///tmp/pub-dartlang-dartdocNNDXIB/pkg/lib/PauloniaRepository.dart:1:9)
            Dartdoc generates a path and filename to write to for each symbol.
            paulonia_repository conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
Found 5 warnings and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:257:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:31:19)
<asynchronous suspension>

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:paulonia_repository/PauloniaRepository.dart that imports:
  • package:paulonia_document_service/paulonia_document_service.dart that imports:
  • package:paulonia_utils/paulonia_utils.dart that imports:
  • package:paulonia_utils/paulonia_utils_mobile.dart that imports:
  • package:device_info/device_info.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cloud_firestore^1.0.71.0.72.4.0
flutterflutter0.0.00.0.0
get^4.1.44.3.44.3.4
paulonia_document_service^0.2.00.2.00.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
cloud_firestore_platform_interface-4.0.35.3.0
cloud_firestore_web-1.0.72.3.0
collection-1.15.01.15.0
connectivity-3.0.63.0.6
connectivity_for_web-0.4.00.4.0
connectivity_macos-0.2.00.2.0
connectivity_platform_interface-2.0.12.0.1
device_info-2.0.22.0.2
device_info_platform_interface-2.0.12.0.1
firebase_core-1.4.01.4.0
firebase_core_platform_interface-4.0.14.0.1
firebase_core_web-1.1.01.1.0
flutter_web_plugins-0.0.00.0.0
js-0.6.30.6.3
meta-1.3.01.7.0
ntp-2.0.02.0.0
paulonia_utils-0.3.00.3.0
plugin_platform_interface-2.0.12.0.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.7` on cloud_firestore does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions cloud_firestore to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

1
likes
110
pub points
53%
popularity

Publisher

paulonia.dev

Package with abstract class for create Models and Repositories

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cloud_firestore, flutter, get, paulonia_document_service

More

Packages that depend on paulonia_repository