parse_server_sdk 7.0.0 copy "parse_server_sdk: ^7.0.0" to clipboard
parse_server_sdk: ^7.0.0 copied to clipboard

The Dart SDK to connect to Parse Server. Build your apps faster with Parse Platform, the complete application stack.

142
likes
150/ 160
pub points
88%
popularity

We analyzed this package 27 hours ago, and awarded it 150 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/parse-community/Parse-SDK-Flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

241 out of 655 API elements (36.8 %) have documentation comments.

Some symbols that are missing documentation: flutter_parse_sdk, flutter_parse_sdk.CoreStore, flutter_parse_sdk.CoreStore.CoreStore, flutter_parse_sdk.CoreStore.clear, flutter_parse_sdk.CoreStore.containsKey.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:parse_server_sdk/parse_server_sdk.dart that imports:
  • package:parse_server_sdk/src/network/parse_http_client.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.19.0 1.19.0
cross_file ^0.3.3+7 0.3.4+1 0.3.4+1
dio ^5.4.2+1 5.4.3+1 5.4.3+1
http ^1.1.0 1.2.1 1.2.1
meta ^1.12.0 1.15.0 1.15.0
mime ^1.0.4 1.0.5 1.0.5
path ^1.9.0 1.9.0 1.9.0
sembast ^3.6.0 3.7.1+2 3.7.1+2
sembast_web ^2.2.0 2.4.0+2 2.4.0+2
timezone ^0.9.2 0.9.3 0.9.3
universal_io ^2.2.2 2.2.2 2.2.2
uuid ^4.3.3 4.4.0 4.4.0
web_socket_channel ^2.4.0 2.4.5 3.0.0
xxtea ^2.1.0 2.1.0 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
crypto - 3.0.3 3.0.3
fixnum - 1.1.0 1.1.0
http_parser - 4.1.0 4.1.0
idb_shim - 2.5.0+1 2.5.0+1
source_span - 1.10.0 1.10.0
sprintf - 7.0.0 7.0.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
synchronized - 3.1.0+1 3.1.0+1
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.4.0` on web_socket_channel does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions web_socket_channel to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

142
likes
150
pub points
88%
popularity
screenshot

Publisher

verified publisherparseplatform.org

The Dart SDK to connect to Parse Server. Build your apps faster with Parse Platform, the complete application stack.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#parse #parse-platform #parse-server #node-js #backend

Documentation

Documentation
API reference

Funding

Consider supporting this project:

opencollective.com
github.com

License

Apache-2.0 (LICENSE)

Dependencies

collection, cross_file, dio, http, meta, mime, path, sembast, sembast_web, timezone, universal_io, uuid, web_socket_channel, xxtea

More

Packages that depend on parse_server_sdk